Phpstorm 安装 laravel扩展,laravel代码提示插件

Phpstorm 安装 laravel扩展,laravel代码提示插件

1.    安装laravel插件

    

2.    配置laravel插件

 

3.    在这里安装laravel的提示插件 barryvdh/laravel-ide-helper

        

这里有可能报错:如下

Failed to decode response: zlib_decode(): data error
Retrying with degraded mode, check https://getcomposer.org/doc/articles/troubleshooting.md#degraded-mode for more info
Your configuration does not allow connection to http://packagist.org. See https://getcomposer.org/doc/06-config.md#secure-http for details.
http://packagist.org could not be fully loaded, package information was loaded from the local cache and may be out of date
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package barryvdh/laravel-ide-helper could not be found in any version, there may be a typo in the package name.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.



可以参考如下的解决方案:

http://www.zhangxihai.cn/archives/108

在命令行执行如下的命令

composer require barryvdh/laravel-ide-helper
   

ps: 请确保在你的项目中的composer.json文件中有如下配置

require”: {
    “php”: “>=5.5.9”,
    “laravel/framework”: “5.2.*”,
    “barryvdh/laravel-ide-helper”: “^2.1”
},

安装成功后的提示:
    
 
$ composer require barryvdh/laravel-ide-helper

Cannot create cache directory /Users/yangyulong/.composer/cache/repo/https—packagist.phpcomposer.com/, or directory is not writable. Proceeding without cache

Using version ^2.1 for barryvdh/laravel-ide-helper

./composer.json has been updated

Cannot create cache directory /Users/yangyulong/.composer/cache/repo/https—packagist.phpcomposer.com/, or directory is not writable. Proceeding without cache

Loading composer repositories with package information

Updating dependencies (including require-dev)

  - Installing symfony/class-loader (v3.0.3)

    Downloading: 100%

  - Installing barryvdh/laravel-ide-helper (v2.1.4)

    Downloading: 100%

symfony/class-loader suggests installing symfony/polyfill-apcu (For using ApcClassLoader on HHVM)

barryvdh/laravel-ide-helper suggests installing doctrine/dbal (Load information from the database about models for phpdocs (~2.3))

坚持原创技术分享,您的支持将鼓励我继续创作!
//